Welcome to GOFASTMOTORSPORTS.com ... ... ... Green Flag - Green Flag - Go Go Go ... ... Brought to you by Ricks Satellite - Where the Big Dish Rules!

Ricks Satellite Wildfeed and Backhaul Forum
Register Latest Topics
 
 
 


Reply
  Author   Comment   Page 6 of 169     «   Prev   3   4   5   6   7   8   9   Next   »
DarkSky

Registered:
Posts: 2,232
Reply with quote  #76 
Quote:
Originally Posted by signalquest
Can you please explain how I should use make menu config?  Is there a default setting that will ensure all my basic hardware will be supported including my PROF 7500? 


Evertything was there for my prof 7301. I would bet the the 7500 will work also. All I did was:

sudo make menuconfig - When the menu came up; I immediately then backed out with the exit button (hit "e" or right arrow to get to it). It will ask you if you want to create a. config file and you say yes. (did this to create .config file; did not see one in initial pull)

make deb-pkg
sudo dpkg -i ../linux-*deb

Then restarted the computer.

You can compile module later if your 7500 does not work with:
sudo make menuconfig - and find your modules, exit out, save new .config
make modules
sudo make modules_install

restart computer

There are so many menus to search through to find your chips.


updatelee

Avatar / Picture

Registered:
Posts: 3,096
Reply with quote  #77 
make menuconfig

# lets you choose what modules are compiled

make deb-pkg

# makes debian packages

make install

# will install the kernel directly, you can use this if you want but I recommend deb-pkg, it makes it so much easier to uninstall later

make modules

# will just make anything listed in menuconfig with 'M' for module and not the entire kernel

make modules_install

# will install those compiled modules

UDL

__________________
TBS6925/5980, Prof 7301/7500/8000, Genpix Skywalker-1, Skystar 2 Express HD
Hauppauge 950Q/Aero/Aero-m, Kworld 330U/435v3/445v3

I use Linux and support open source projects
Download my opensrc projects at http://updatelee.blogspot.com
andyinyakima

Avatar / Picture

Registered:
Posts: 1,511
Reply with quote  #78 
Quote:
# will just make anything listed in menuconfig with 'M' for module and not the entire kernel


UDL
Started to think about menuconfig after my last reply, 'M' clarified it for me.

DarkSky, I agree with you of the depth of the directories. I still get turned around if it ain't in my home directory.
But with power comes complexity. Did ya see the maintainers list; lota hands in the kernel maintenance.

Thanks UDL

__________________
andyinyakima
-----------------------------------
Recs: TBS6983, TBS5925 __ Ant: 90cm on SG6100__OSes: Linux with v4l-updatelee drivers __ RPi2 with v4l-updatelee drivers

Open Book, Open Source, You have to Open it to Know what's in it!
signalquest

Registered:
Posts: 416
Reply with quote  #79 
Getting this error.  How do I resolve this?  Thanks.

Errors were encountered while processing:
 ../linux-libc-dev_3.11.0-rc2+-5_i386.deb

__________________
10' MESH w/ DMX241, and GBOX w/ Von Weise Actuator
1 meter KU w/ SG2100 rotor
PROF 7500 w/ Linux using XBMC, TVHeadend, blindscan-s2, and tune-s2
DarkSky

Registered:
Posts: 2,232
Reply with quote  #80 
Quote:
Originally Posted by signalquest
Getting this error.  How do I resolve this?  Thanks.

Errors were encountered while processing:
 ../linux-libc-dev_3.11.0-rc2+-5_i386.deb


Was the error in the building stage; Did you install all the dependencies in README?

sudo apt-get install mercurial build-essential linux-headers-generic ncurses-dev libproc-processtable-perl

( I have wondered why fakeroot was not in the list. I already had it installed while I was building my own kernels; It was always seemed to be reguired in the instructions) There are other things I have installed also; depending on whose instructions I was going by at the time.

installation stage;  did you leave out sudo

sudo
dpkg -i ../linux-*deb
updatelee

Avatar / Picture

Registered:
Posts: 3,096
Reply with quote  #81 
Darksky: is fakeroot required? I havent done a fresh install in forever. If it is I'll update the README

UDL

__________________
TBS6925/5980, Prof 7301/7500/8000, Genpix Skywalker-1, Skystar 2 Express HD
Hauppauge 950Q/Aero/Aero-m, Kworld 330U/435v3/445v3

I use Linux and support open source projects
Download my opensrc projects at http://updatelee.blogspot.com
DarkSky

Registered:
Posts: 2,232
Reply with quote  #82 
Quote:
Originally Posted by updatelee
Darksky: is fakeroot required? I havent done a fresh install in forever. If it is I'll update the README

UDL


I really do not know. What I do know is that guides I have seen for building debs seems to want it installed. But you sometimes do not know how old the guides are. Things change on how you do things over time.

I think basically it lets you build packages to be installed and work right in root privileged areas of the operating system with out having to build them as root. 

Definition: fakeroot: Gives a fake root environment. This package is intended to enable something like: dpkg-buildpackage -rfakeroot i.e. to remove the need to become root for a package build. This is done by setting LD_PRELOAD to libfakeroot.so, which provides wrappers around getuid, chown, chmod, mknod, stat...
signalquest

Registered:
Posts: 416
Reply with quote  #83 
I have installed all dependencies and I am doing everything as root.  

That is the last output after I "dpkg -i ../linux-*deb"

......
Found memtest86+ image: /boot/memtest86+.bin
done
Setting up linux-libc-dev (3.11.0-rc2+-6) ...
Errors were encountered while processing:
 ../linux-libc-dev_3.11.0-rc2+-5_i386.deb

__________________
10' MESH w/ DMX241, and GBOX w/ Von Weise Actuator
1 meter KU w/ SG2100 rotor
PROF 7500 w/ Linux using XBMC, TVHeadend, blindscan-s2, and tune-s2
DarkSky

Registered:
Posts: 2,232
Reply with quote  #84 
Quote:
Originally Posted by signalquest
I have installed all dependencies and I am doing everything as root.  

That is the last output after I "dpkg -i ../linux-*deb"

......
Found memtest86+ image: /boot/memtest86+.bin
done
Setting up linux-libc-dev (3.11.0-rc2+-6) ...
Errors were encountered while processing:
 ../linux-libc-dev_3.11.0-rc2+-5_i386.deb


Looks like to me you have conflicting versions for some reason. I would do a fresh pull and recompile. It does not make sense to me for it to set up one version and at the same time try to process it as another.
updatelee

Avatar / Picture

Registered:
Posts: 3,096
Reply with quote  #85 
Good catch Darksky.

start fresh, 

rm -R ../*deb
make deb-pkg
sudo dpkg -i ../*deb

UDL

__________________
TBS6925/5980, Prof 7301/7500/8000, Genpix Skywalker-1, Skystar 2 Express HD
Hauppauge 950Q/Aero/Aero-m, Kworld 330U/435v3/445v3

I use Linux and support open source projects
Download my opensrc projects at http://updatelee.blogspot.com
signalquest

Registered:
Posts: 416
Reply with quote  #86 
root@cap:/usr/src/v4l-updatelee-git# uname -a
Linux cap 3.11.0-rc2+ #6 SMP Sun Jul 28 22:46:33 EDT 2013 i686 i686 i686 GNU/Linux

__________________
10' MESH w/ DMX241, and GBOX w/ Von Weise Actuator
1 meter KU w/ SG2100 rotor
PROF 7500 w/ Linux using XBMC, TVHeadend, blindscan-s2, and tune-s2
updatelee

Avatar / Picture

Registered:
Posts: 3,096
Reply with quote  #87 
k, well you obviously cant install a new kernel ontop of the same kernel.

not sure what your trying todo here, youve already got 3.11.0-rc2 installed

UDL

__________________
TBS6925/5980, Prof 7301/7500/8000, Genpix Skywalker-1, Skystar 2 Express HD
Hauppauge 950Q/Aero/Aero-m, Kworld 330U/435v3/445v3

I use Linux and support open source projects
Download my opensrc projects at http://updatelee.blogspot.com
signalquest

Registered:
Posts: 416
Reply with quote  #88 
I had an error about disk space during my first attempt.  So I made more space and started over.
__________________
10' MESH w/ DMX241, and GBOX w/ Von Weise Actuator
1 meter KU w/ SG2100 rotor
PROF 7500 w/ Linux using XBMC, TVHeadend, blindscan-s2, and tune-s2
DarkSky

Registered:
Posts: 2,232
Reply with quote  #89 
Maybe he was trying to upgrade his modules.

If you recompiled everything again after make menuconfig do:
sudo make modules_install

reboot

If you have not compiled after make menuconfig do:
make modules
sudo make modules_install

reboot


DarkSky

Registered:
Posts: 2,232
Reply with quote  #90 
Saw today on kernel.org they upgraded to 3.11-rc3 today. Does that mean a future pull on v4l-updatelee-git will include it? Not complaining as I need something to occupy my time and mind. And at the same time there may be needed bug fixes; being that it is a release candidate.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Fellow Members, your posts are welcome here! Do not worry about posting everything perfect. Different receivers and LNB's will give you different Frequencies and Symbol Rates. Some set top boxes, PCI cards and USB receivers, Do Not Require all of the same information that others may need. It is not Required to post everything that others may need to tune in a feed. It is just most important to share the find. We can always adjust the Frequency and Symbol Rates and try the various Modulations and FEC's on our own receivers until we get a lock and then give a polite reply with what works for your receiver, as that information might help others as well. We all appreciate the efforts and energy of the Posters!

Thank You for Visiting GOFASTMOTORSPORTS.com - Keep Your Eyes on the Sky and the Track!