Welcome to GOFASTMOTORSPORTS.com ... ... ... Green Flag - Green Flag - Go Go Go ... ... Brought to you by Ricks Satellite - Where the Big Dish Rules!

Ricks Satellite Wildfeed and Backhaul Forum
Register Latest Topics
 
 
 


Reply
  Author   Comment   Page 1 of 28      1   2   3   4   Next   »
dazulrich

Registered:
Posts: 204
Reply with quote  #1 
All,
Instead of more 5.3 builds, I've created an unofficial v6.0 test build for Azbox ME and miniME. (as 6.0 is beta I'll concentrate on getting the fixes into 6.0 final, and then 5.3)
They contain the existing attempts to address the most annoying Spinner issues associated with media playback.

Those changes still have not been pushed to the OE-A or Openatv repos. (I have patches ready to go when needed)
There is some more work planned on the generic mediasink and the main servicemp3 code in E2.
I'll see where this is going and how this affects my existing changes before committing the patches to the repo.

In addition to the 5.3 build , i've made a change regarding unpausing media. Need to do a bit of testing and might change in the next test build.
Let me know if that is badly broken now.

I have committed some smaller changes that have made it into the official 6.0 beta builds (and are of course in my test builds as well).
Fixed Z button launch of BoxPortal , to switch radio/tv or launch media player (after EMC launch override was changed in EMC setup)
Fixed deep standby (no more reboot when no timer set)
Fixed some WebIF rcu codes

For those of you, who have experienced annoying spinner during media playback with their ME in the past , please have a look and give this image a good bash.
For everyone else, download and use the test build and please report back any positive / negative feedback, to improve the final result.

As I only have ME and no miniME, no testing of the miniME build has been done.. please let me know whether its working or not!!

You can use the normal feed to update plugins, but you can't update the test image without loosing my changes.

The builds were made against the current git repo commits as of 15th Jan (using local patches).

ME:
https://www.dropbox.com/s/mrlrbwp4di6utac/openatv-6.0-azboxme-dazulrich_usb.zip?dl=0
https://www.dropbox.com/s/zrz8neu1yvj1rx1/openatv-6.0-azboxme-dazulrich_webif.zip?dl=0

miniME:
https://www.dropbox.com/s/t4nwxo3j2q4t3fe/openatv-6.0-azboxminime-dazulrich_usb.zip?dl=0
https://www.dropbox.com/s/9ozzz1p5m9ta60l/openatv-6.0-azboxminime-dazulrich_webif.zip?dl=0

Enjoy
/dazulrich
mountaineer

Avatar / Picture

Registered:
Posts: 2,609
Reply with quote  #2 
Thank You!!!!!
__________________
3 Edison OS mini's, 3 Openbox S10s, 2 Openbox S9's, NFusion HD, 2 Prof 7500's, Genpix Skywalker 1, 2 Optibox Anacondas, Azbox me, Azbox minime, 2 Jynxboxes, ismart m100, izzibox, TBS 6982, Vigica C60s, Optibox Raptor, azbox Bravissimo, TBS 5922SE, TBS 5980 (Broke), and TBS 6902.
 36" KU Dish Linear, 10 ft prime focus Mesh, 7.5ft prime focus mesh dish C and KU.
7 Stationary KU dishes.
rickp

Avatar / Picture

Registered:
Posts: 699
Reply with quote  #3 
quote  You can use the normal feed to update plugins, but you can't update the test image without loosing my changes....... important to note

thank you, what kernel is required and  blindscan C band capable?

__________________
3.8M Patriot solid Navigator dual axis mount.3.1M Patriot solid polar mount.10Ft Unimesh 8ft Winegard 1.m and 1.2m Primestar.DTE7100 4DTV922 ,Chaparral 140&95. AZME&Ultra Prof 7301 Alien1 Geo MicroHD
catamount

Registered:
Posts: 28
Reply with quote  #4 
Thanks Dazulrich!

Updated by usb.  It froze erasing MTD4@18%,  but after reboot it went through smoothly the second try.  Seems to work fine on the MiniMe.  Pause/unpausing media works in this build.  Only about a three second delay after unpausing. (almost as good as 4.2 build).

Don't see any issues!  No spinners at all using the media player.  Let me know if you require Minime testing on something.

@ Rickp the kernal is 3.9.2

Catamount
mountaineer

Avatar / Picture

Registered:
Posts: 2,609
Reply with quote  #5 
Dazulrich,
 Great work! I also will be testing on the minime and me. I just wonder if you live here in north america if you could figure out why none of the images will record the 4:2:2 CBS feeds on Cband G 19 4080 V 29860 . It seems that it eats up the memory and shuts off the recordings sometimes at 10 seconds sometimes 10 minutes the most is at around 20-30 minutes. There was an image that worked well with recording but that was several kernels ago I think. If you dont live in NA then I dont know how we could get you to test it. Any help is appreciated!

__________________
3 Edison OS mini's, 3 Openbox S10s, 2 Openbox S9's, NFusion HD, 2 Prof 7500's, Genpix Skywalker 1, 2 Optibox Anacondas, Azbox me, Azbox minime, 2 Jynxboxes, ismart m100, izzibox, TBS 6982, Vigica C60s, Optibox Raptor, azbox Bravissimo, TBS 5922SE, TBS 5980 (Broke), and TBS 6902.
 36" KU Dish Linear, 10 ft prime focus Mesh, 7.5ft prime focus mesh dish C and KU.
7 Stationary KU dishes.
babadem

Avatar / Picture

Registered:
Posts: 667
Reply with quote  #6 
Thanks, Dazulrich for all you efforts! I will download and test with AZBoxMe and report back my findings!
__________________
Amiko-A3, AZBox Me, MicroHD, and TBS6903. DG-380 Motor (43.1°W to 127.0°W), on 1.2M Geosat Pro.  3ABN Dish @30.0°W. 2nd 1.2M looking @103.0°W. 12FT Paraclipse Dish looking from 37.5°W to 111.1°W.
dazulrich

Registered:
Posts: 204
Reply with quote  #7 
@rickp: its kernel 3.9.2 (just like all images for past few years...) . I don't know what the blindscan utility can/can't do. Its prebuild coming from the old, defunct openazbox team.

@mountaineer: No i'm not in NA, I live in Europe. can you try recording the feed with a different box and they try playing it with Azbox?
If that crashes the box we might have something to test with... (but as with everything azbox, if its the buggy driver, then options are limited...)

pause/unpause is is hit and miss for me, depending on codec.
I'll try a few more variations over coming days.
If the feedback across ME and miniME testing is that spinner are fixed and didn't introduced new issues, i'll commit the patches.

(for background info what is causing the issues - maybe one of you knows all about linux kernel/drive development and can provide some suggestions what else could be done / how to test.
- the skins and a resolution change detection routine read resolution / framerate data from the driver (via some /proc values).  this is working fine in TV mode, but during media playback, those same calls will take MUCH, MUCH longer to complete, with the result that the python script hangs , and Enigma hangs -> hence the spinner and UI and remote locked until the driver responds with the requested value. - those are cached, hence the spinner is caused by the first calls to each of those procs
- the skins also constantly call the driver via some E2 C++ code to display the playposition.
Same thing happens. A call to the driver for the stb time is blocking further execution of E2 till the result is returned.

I've patches some python files to use calls to gstreamer to return the video resolution and framerate instead calling the box driver. (this is how it is done in openpli, so should be ok to do..)
I've patched the E2 servicemp3 C++ code to use the audiosink instead of the videosink to call driver for system time, for some reasons this is not blocking.. - (again this the way it used to be in openpli until recently. So it was considered ok to do. the recent change in openpli, causes HDMU to show spinner as they changed to call videosink as well. )

I consider the patch to be to two parts. the python patches and the E2 code patches.
I'll commit the python patches first as they is not contingent on any other changes at this stage. (subject to testing thumbs up)

/daz
mountaineer

Avatar / Picture

Registered:
Posts: 2,609
Reply with quote  #8 
dazulrich

loaded it on azminime. Had to load emc. tried to play other ts files recorded with smartdvb and would not even start to play them. AZplay is listed as a plugin and will install...however upon opening it blue screen of death. I used media player and easy media player with same results. Would play CBS 4:2:2 high bitrate fine both from a recording (25 min) and by tuning. Would record only 2 seconds of it though...also ABC non 422 high bit rate same result. So it seems it can play the stream whether live or recording...however it will not record it. Maybe you can find the highest bitrate signal in europe and see how it does.  Shutdown and startup work great! Also broken for a long time is the network mounts....cant play anything from another azbox or computer will not CIS mount them.
Thnks for all you are doing will continue to test!

__________________
3 Edison OS mini's, 3 Openbox S10s, 2 Openbox S9's, NFusion HD, 2 Prof 7500's, Genpix Skywalker 1, 2 Optibox Anacondas, Azbox me, Azbox minime, 2 Jynxboxes, ismart m100, izzibox, TBS 6982, Vigica C60s, Optibox Raptor, azbox Bravissimo, TBS 5922SE, TBS 5980 (Broke), and TBS 6902.
 36" KU Dish Linear, 10 ft prime focus Mesh, 7.5ft prime focus mesh dish C and KU.
7 Stationary KU dishes.
dazulrich

Registered:
Posts: 204
Reply with quote  #9 
Can you post the crash log when opening azplay? Any small ts file that won't play you could upload anywhere.

The recording failure. Can you start E2 from cm/s line, to Produktdesign log and try recording. Post the output (or piped into log). Maybe that will show something.
mountaineer

Avatar / Picture

Registered:
Posts: 2,609
Reply with quote  #10 
where are the crash logs stored
__________________
3 Edison OS mini's, 3 Openbox S10s, 2 Openbox S9's, NFusion HD, 2 Prof 7500's, Genpix Skywalker 1, 2 Optibox Anacondas, Azbox me, Azbox minime, 2 Jynxboxes, ismart m100, izzibox, TBS 6982, Vigica C60s, Optibox Raptor, azbox Bravissimo, TBS 5922SE, TBS 5980 (Broke), and TBS 6902.
 36" KU Dish Linear, 10 ft prime focus Mesh, 7.5ft prime focus mesh dish C and KU.
7 Stationary KU dishes.
dazulrich

Registered:
Posts: 204
Reply with quote  #11 
In /home/root/logs

Howto to get enigma debug log
http://www.opena.tv/howtos/52-log-files-kleines.html ( in german)
I had posted steps in the 5.3 test image thread.
mountaineer

Avatar / Picture

Registered:
Posts: 2,609
Reply with quote  #12 
sorry logs werent enabled..redid it.
txt enigma2_crash_1484586640.txt     txt enigma2_crash_1484586640.txt     txt enigma2_crash_1484586640.txt     txt enigma2_crash_1484586640.txt     txt enigma2_crash_1484586935.txt     txt enigma2_crash_1484590572.txt     txt Enigma2-debug-20170116_13-15-19.txt     txt Enigma2-debug-20170116_13-16-24.txt     




__________________
3 Edison OS mini's, 3 Openbox S10s, 2 Openbox S9's, NFusion HD, 2 Prof 7500's, Genpix Skywalker 1, 2 Optibox Anacondas, Azbox me, Azbox minime, 2 Jynxboxes, ismart m100, izzibox, TBS 6982, Vigica C60s, Optibox Raptor, azbox Bravissimo, TBS 5922SE, TBS 5980 (Broke), and TBS 6902.
 36" KU Dish Linear, 10 ft prime focus Mesh, 7.5ft prime focus mesh dish C and KU.
7 Stationary KU dishes.
mountaineer

Avatar / Picture

Registered:
Posts: 2,609
Reply with quote  #13 
https://www.dropbox.com/s/owgx1srnyelrdx9/Church%20Channel20170116-132637.ts?dl=0

Quick simple .ts file

__________________
3 Edison OS mini's, 3 Openbox S10s, 2 Openbox S9's, NFusion HD, 2 Prof 7500's, Genpix Skywalker 1, 2 Optibox Anacondas, Azbox me, Azbox minime, 2 Jynxboxes, ismart m100, izzibox, TBS 6982, Vigica C60s, Optibox Raptor, azbox Bravissimo, TBS 5922SE, TBS 5980 (Broke), and TBS 6902.
 36" KU Dish Linear, 10 ft prime focus Mesh, 7.5ft prime focus mesh dish C and KU.
7 Stationary KU dishes.
mountaineer

Avatar / Picture

Registered:
Posts: 2,609
Reply with quote  #14 
record attempt


 
Attached Files
txt Enigma2-debug-20170116_13-16-24.txt (351.06 KB, 6 views)


__________________
3 Edison OS mini's, 3 Openbox S10s, 2 Openbox S9's, NFusion HD, 2 Prof 7500's, Genpix Skywalker 1, 2 Optibox Anacondas, Azbox me, Azbox minime, 2 Jynxboxes, ismart m100, izzibox, TBS 6982, Vigica C60s, Optibox Raptor, azbox Bravissimo, TBS 5922SE, TBS 5980 (Broke), and TBS 6902.
 36" KU Dish Linear, 10 ft prime focus Mesh, 7.5ft prime focus mesh dish C and KU.
7 Stationary KU dishes.

babadem

Avatar / Picture

Registered:
Posts: 667
Reply with quote  #15 
Great job Mountaineer!!! [thumb]

My limited test confirm that the TV\Video button has been fixed and Deep Standby works as it should. Using the Media Player: Movie in the Library plays fine, but if you pause the movie it doesn't un-pause, but there are no spinners.
On a side note, for "Linear" KU Blindscan; In Tuner Configuration, choosing LOF of "Circular LNB" will allow you to scan Linear Frequencies with a LO of 10750. I noticed this option in Ver 5.3. I guess they must have taken a page from EL Bandido's experiment for BlindScan-NA sometime ago. I'm glad the option is there now!

__________________
Amiko-A3, AZBox Me, MicroHD, and TBS6903. DG-380 Motor (43.1°W to 127.0°W), on 1.2M Geosat Pro.  3ABN Dish @30.0°W. 2nd 1.2M looking @103.0°W. 12FT Paraclipse Dish looking from 37.5°W to 111.1°W.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Fellow Members, your posts are welcome here! Do not worry about posting everything perfect. Different receivers and LNB's will give you different Frequencies and Symbol Rates. Some set top boxes, PCI cards and USB receivers, Do Not Require all of the same information that others may need. It is not Required to post everything that others may need to tune in a feed. It is just most important to share the find. We can always adjust the Frequency and Symbol Rates and try the various Modulations and FEC's on our own receivers until we get a lock and then give a polite reply with what works for your receiver, as that information might help others as well. We all appreciate the efforts and energy of the Posters!

Thank You for Visiting GOFASTMOTORSPORTS.com - Keep Your Eyes on the Sky and the Track!