Welcome to GOFASTMOTORSPORTS.com ... ... ... Green Flag - Green Flag - Go Go Go ... ... Brought to you by Ricks Satellite - Where the Big Dish Rules!

Ricks Satellite Wildfeed and Backhaul Forum
Register Latest Topics
 
 
 


Reply
  Author   Comment  
wejones

Avatar / Picture

Registered:
Posts: 5,574
Reply with quote  #1 
Wasn't sure whether to put this here in the Azbox section or in computer section since it's computer related, but after reading the JTAG thread today, I started browsing through my Azbox Elite via the network.  I did a listing of / and then did a DF command to list the filesystem, then did listings of all the primary directories.
THEN, I made a mistake, I highlighted the history of what I had just done, and thinking Windows, I think I did a right click, intending to do a copy/paste, forgetting that in Putty, the right click copies everything highlighted to the command line. I've done this before, and it's rather scary, not knowing what commands might be executed while seeing all sorts of things scrolling up the screen before I could stop it.
Well, after it was done, it seemed like I had lucked out (again, since I had done this before several times), as everything still seemed to be working OK.
Anyway, I closed out of the terminal, but then logged onto the Azbox again a while later.  When I did this, I was surprised to see:

vfd_chartable.txt* login:
instead of
AZBox login:

Confused, I shut down Putty, and tried again, but got the same result. I then looked at the copy of what I had sent to the command line (see attached), and noticed that down near the bottom, where I was listing the contents of /DISK2, there was the line:

hostname                     vfd_chartable.txt*

So I figured that this had to be what had happened, ie this line executed the hostname command and changed it.
However then, I was worried that something else had executed, so I looked at the Azbox on TV, and noticed that the screen was frozen, so I rebooted.
After rebooting, I noticed that everything was working again, but the host name had changed back to Azbox again. This actually worried me more, because I had thought that the only way this would happen was if there was a corruption and the boot didn't work, which would cause it to revert to the backup version of /DISK2 that's kept in the /DISK1 directory, and when this happens, it usually changes all the satellite data in the 3 .dat files to the default, which requires me to copy my saved copies back into /DISK2.
However on checking the Azbox sat lists, they were all just as they were before my mistake.

Anyway, I'm glad that it didn't seem to corrupt anything, but I'm really confused re why the hostname would be switched back to the backup value, but the .dat files weren't replaced by their backups?

Only thing I can think of is that perhaps at bootup, the Azbox selectively changes only files that it thinks need replacing rather than replacing all of them.  Either that, or maybe there is some bug that prevents the hostname from being changed permanently?
There were a couple scripts in the /DISK1 directory, ie check_hda.sh* and launch.sh* that looked like they might be responsible for checking for corruption, but I don't understand everything I'm reading in the scripts to know for sure.

Anyway, I think I lucked out again, but wanted to warn people about using Putty to log onto the Azbox to be careful with right clicks of the mouse. And also ask whether anyone has ideas why the hostname change wasn't permanent.

 
Attached Files
txt zzzzz.txt (1.82 KB, 12 views)

majortom

Avatar / Picture

Registered:
Posts: 4,856
Reply with quote  #2 
I am guessing you would want to understand the boot process to understand.
There are a few books one can read up on embedded linux systems here:
https://github.com/shihyu/Embedded_Systems/tree/master/books

I have not read them.

You can disable the mouse rt click to paste function in putty
http://morgamic.com/2012/06/22/disabling-right-click-to-paste-in-putty/


__________________
Perfect 10 7.5' mesh Chapparal C/Ku Co-Rotor feed, Norsat 8115 CBAND, Norsat 4106A Ku Thomson Saginaw Actuator, Vbox positioner,
Home Brew Polarotor683 Servo circuit. Openbox S9, Prof7500, v4l-updatelee linux drivers installed.
wejones

Avatar / Picture

Registered:
Posts: 5,574
Reply with quote  #3 
Thanks for the links.
  I was actually close to the first link yesterday when I was googling mtdblocks, which took me into a couple imbeded systems documents at that github site.  I didn't understand much, but browsing through your document is starting lights to blink in my brain.  Interestingly described some procedures used on the old TIVO units to define how it boots.  I didn't understand what I was doing at the time, but this helped explain it. 

Redisabling the right click function in Putty.  Just did that and that helped. I hadn't noticed that setting.

More strangeness today, however.  Yesterday, I was able to use the hostname command to change the hostname, at least temporarily.  Today it still had the changed name I had created yesterday.  However today I can't change it, and on rebooting, it's back to AZBOX.  The Azbox seems to have both a file named hostname and a program called hostname, which is confusing me.  I can run the hostname program to get the help screen, but on running it, it doesn't seem to function anymore.  Strange.

Anyway, thanks.  I've got some reading to do.

mountaineer

Avatar / Picture

Registered:
Posts: 2,640
Reply with quote  #4 
Check in the samba folder/file. In linux under user. smb.conf I think. The name there is the name displayed I think. Not sure on any box but AZME and MINIME which run E2 of course. But other linux fw have the same file that I have seen. Might be worth a look.
__________________
3 Edison OS mini's, 3 Openbox S10s, 2 Openbox S9's, NFusion HD, 2 Prof 7500's, Genpix Skywalker 1, 2 Optibox Anacondas, Azbox me, Azbox minime, 2 Jynxboxes, ismart m100, izzibox, TBS 6982, Vigica C60s, Optibox Raptor, azbox Bravissimo, TBS 5922SE, TBS 5980 (Broke), and TBS 6902.
 36" KU Dish Linear, 10 ft prime focus Mesh, 7.5ft prime focus mesh dish C and KU.
7 Stationary KU dishes.
wejones

Avatar / Picture

Registered:
Posts: 5,574
Reply with quote  #5 
Quote:
Originally Posted by mountaineer
Check in the samba folder/file. In linux under user. smb.conf I think. The name there is the name displayed I think. Not sure on any box but AZME and MINIME which run E2 of course. But other linux fw have the same file that I have seen. Might be worth a look.

   Thanks.....
I found the samba folder and smb.conf file.  They were in the /MMP/etc/   directory.  However there didn't seem to be any mention of hostname there.   There was some curious behavior, however, in that I found the file by doing a:
ls -laR|grep samba
This found the file quickly, but while still searching something went wrong, and the Azbox froze up, and I had to reboot. This happened 3 times, so something strange going on there. 

While experimenting, I found out that I CAN change the hostname.
It turns out that when the hostname  xxx command is issued, the actual change doesn't occur until the next time you log on with Putty.  However as mentioned before this is only a temporary change and it reverts to Azbox if the Azbox is rebooted.
    Also, as mentioned before, there is a file named hostname in the /DISK2 directory.  This directory seems to be where user changeable variables are stored, such as the .dat files with the sat/channel data.  After using the hostname command, I checked and this hostname file was not changed, it was still "azbox".   So I edited this file, changing it to BJ-Azbox.  When I did that, and rebooted the Azbox, the change was permanent. 

     So that pretty much clears up my confusion relative to the hostname changing and then reverting to the old one. 


Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Fellow Members, your posts are welcome here! Do not worry about posting everything perfect. Different receivers and LNB's will give you different Frequencies and Symbol Rates. Some set top boxes, PCI cards and USB receivers, Do Not Require all of the same information that others may need. It is not Required to post everything that others may need to tune in a feed. It is just most important to share the find. We can always adjust the Frequency and Symbol Rates and try the various Modulations and FEC's on our own receivers until we get a lock and then give a polite reply with what works for your receiver, as that information might help others as well. We all appreciate the efforts and energy of the Posters!

Thank You for Visiting GOFASTMOTORSPORTS.com - Keep Your Eyes on the Sky and the Track!